EV Charge API - Node restart

Incident Report for Tridens

Postmortem

Incident Summary

We identified increased memory pressure in the EV Charge service, which may have caused slower responses or intermittent errors for some users.

The issue was related to unnecessary internal processing of larger API responses. This increased memory usage during normal traffic. No customer data was lost or corrupted.

Resolution

We adjusted runtime settings to improve how the service manages memory under load.

With applied settings the service returned to expected memory levels and remained stable.

Customer Impact

Some users may have experienced slower loading times or temporary errors during the affected period between 14:35 - 14:50 CEST.

Follow-Up

We will continue monitoring the service closely and have added additional safeguards to help reduce the chance of similar issues in the future.

Posted May 27, 2026 - 22:50 CEST

Resolved

This incident has been resolved following a node restart. We are continuing to investigate the underlying cause and will provide further details, including the planned fix, in a postmortem.
Posted May 27, 2026 - 15:30 CEST

Update

We are continuing to work on a fix for this issue.
Posted May 27, 2026 - 14:56 CEST

Identified

Our EV Charge API node restarted unexpectedly. The service is currently operating normally while we investigate the root cause.
Posted May 27, 2026 - 14:50 CEST

Investigating

We are currently investigating this issue.
Posted May 27, 2026 - 14:35 CEST
This incident affected: EV Charge (API).